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2 Change History 

 
Version 
 

 
Main Changes from Previous Version 

 
Edited By 

v1.2 Initial Release of quickstart manual FS, DE 

v1.4 Updated into user’s handbook. Version number 
aligned with software version. 

DE 

v1.7 Updated handbook for release of NetLink 1.7. 
Version number aligned with software version. 

DE 29.7.08 

v2.1.1 Updated handbook for release of NetLink 2.1.1. 

Descriptions of different Net-Link operation 
modes. 

Version number aligned with software version 

DE 21.11.08 

v2.3 Updated handbook for release of NetLink 2.3. 

Adapated for new connected unit menu 
structure. Description of video switch selection 
also added. 

Version number aligned with software version. 

DE 5.2.09 
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3 About this Manual 

This manual describes the operation of the domo Net-Link Windows 
Application.  
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4 Introduction 

Welcome to the domo Net-Link user’s handbook. 

This handbook documents fully the features of the domo Net-Link 
Windows Application. This software provides all the decoding and 
management facilities needed to use the Net-Link system. All content 
can be controlled, managed, retrieved and played back to the user. 
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5 Running the Net-Link application for the first time 

5.1 Licensing the Net-Link application 

The first time the Net-Link application is run the user should be prompted 
for a license code with a popup window as follows: 

 

 
 

The user should contact domo with the serial number. A license code will 
then be generated specific for the machine that the application is installed 
on. 
 

5.2 Application mode 

The Net-Link application can operate in two different modes. 

Fixed server mode. In this mode, all communications between the Net-
Link windows application and the Net-Link unit will go through a server 
running on a fixed IP address. 

Netlink server - PC client mode. This is the “traditional” mode of Net-
Link operation, whereas each Net-Link unit acts as a sever which Net-
Link windows applications running on individual PCs connect to as 
clients. 

The default mode, in which the application will start up when first 
installed is “Fixed server”. In this mode the application will try to 
establish a connection to a server located at a fixed IP address on port 
10001. Depending on setup of the computer on which the application is 
running, warning messages may appear to tell the user that the software 
is attempting to connect. It is recommended that the user unblocks any 
firewall settings which attempt to restrict the access of the application. 

The application will attempt, by default, to connect to a server on IP 
address 195.59.167.108. This will normally fail after several seconds, 
presenting the user with the following information window: 
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The user should dismiss this window and then select the “Connection 
options” option from the “Options” menu. A window will appear as 
follows: 

 
If fixed server mode is required, the user should enter the correct IP 
address for the server into the field marked “Server address” and click 
the “Apply” button. If connection to the server fails a window will appear 
to inform the user of this. If it is successful, the text below the server 
address field will change to “Server is connected”. 

If “Netlink server – PC client” mode is required, the user should select 
this from the “Current mode” dropdown box and click the “Apply” button. 
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6 Connecting to Net-Link units 

To connect to a remote Net-Link unit you must know its IP address as 
well as its 16 hex digit unique ID number. 

To establish a connection either click the new connections button on the 
toolbar:  

 
or select the “Create new connection” option from the “Options” menu. 

The type of window which will appear will depend on the mode in which 
the application is operating. 

6.1 Fixed server mode 

The application will request from the server a list of Net-Link units 
available. If the server does not have any connections from Net-Link 
units, a window will appear to inform the user of this as follows: 

 
If any Net-Link units are available to connect to, a popup window will 
appear as follows: 

 
The user should select the ID number of the Net-Link unit they wish to 
connect to from the dropdown box, enter the appropriate username and 
password and click the “OK” button to attempt to establish a connection 
to the Net-Link. 

6.2 Net-Link server – PC client mode 

 A popup window should appear as follows: 
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The user should enter either the IP address or the hostname (if dynamic 
DNS is being used for the Net-Link unit) into the “IP Address” field. The 
“ID” field requires the 16 digit hexadecimal ID of the Net-Link unit being 
connected to (this field is not case-sensitive). The appropriate username 
and password are entered into the relevant fields. When all appropriate 
fields are filled out the user should click the “OK” button to attempt to 
establish a connection to the Net-Link. 

6.3 Established connection view 

If a connection is successfully established an icon representing this 
connection will appear at the bottom of the main window like this:  

 
This icon can then be dragged and dropped into the main work area to 
view live content, or retrieve and view stored content from the unit. 
Alternatively, right-clicking the icon will present a pop-up menu with 
various options relating to the connection. 
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7 Application work area 

7.4 Introduction 

The main window of the application has four main areas: 

 
 

The main workspace can be divided into a number of workspace slots. 
Any one of these slots can be currently selected. The playback control 
area always refers to, and has effect on the currently selected 
workspace slot. 

The content/connections area shows the user the currently available 
sources from which they can set up one of the workspace slots. 

The toolbar and menus provide various options for setting up both the 
application itself and any connected Net-Link units, as well as the 
means to create and manage new Net-Link connections. 

 

7.5 Main workspace area 

When the work area is clicked with the left-button of the mouse, the 
active part should be highlighted in red: 
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Once an area of the window is selected, it can be divided up by either 

clicking the grid divide button  , selecting the “Divide Grid” option 
from the “View” menu, or simply typing Ctrl-D. This will divide the 
selected part of the work area into four smaller areas, each of which can 
then be selected in the usual way: 

 

 
 

An area that has been divided into four sub-areas can be undivided 
again by selecting any of the four sub-areas and either clicking the grid 

undivide button , selecting the “Undivide Grid” option from the 
“View“ menu or typing Ctrl-U. 
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7.6 Content/connections area 

Any slot within the work area can be set up by dragging and dropping 
one of the icons from the content/connections area. There are three icon 
types that may be displayed along the bottom. 

7.6.1 Connection icon 

This icon represents a connection to a Net-Link unit. Dropping 
this icon into a slot will present options for either live or stored content. 
Live content will be a thumbnail stream, stored content can be either 
thumbnails or full frame rate video. 

If live content is selected, the application will attempt to negotiate a 
connection with the Net-Link for the thumbnail stream. If this is 
successful, the user will be prompted for a decryption key when the 
thumbnail images begin to arrive. 

The connection icon can also be right-clicked. The user will then be 
presented with a popup menu containing numerous options for 
configuring the connection. The following options will appear in the 
menu: 

Connection properties. Selecting this option will bring up a popup 
window containing appropriate information about the Net-Link 
connection. This will include the unit mode and features, any external 
units connected to the input slots of the Net-Link and the IP address and 
user login associated with this connection. 

Close connection. Selecting this option will gracefully close the 
connection. Any live streams from the connection will also be shut 
down. 

Also, four sub-menus will appear: Users, Recording, Management 
and Advanced. 

The Users sub-menu contains the following options: 

Edit user(s). This option will only appear if the user logged in has 
supervisor privileges. It enables the user logins to be created and 
deleted. 

View active users. This option will launch a popup window containing a 
list of all currently active users and whether or not any of them are 
currently viewing live thumbnails: 
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The Recordings sub-menu contains the following options: 

Hard disk status. This option will only appear if the connected unit has 
been fitted with a hard disk. A popup window will appear showing the 
capacity of the hard disk and its current occupancy. 

Set recording event. This option will only appear if the connected unit 
has been fitted with a hard disk. A popup window will appear as follows: 

 
The start and stop times the user sets up must be with relation to the 
units own clock. This is displayed at the top of the popup window. For 
Net-Link systems with more than one channel, the event source 
dropdown box can be used to select which channel is to be recorded. 
The checkbox next to this enables or disables the single/multiple 
channel selection. Each recording must also be given a name. 

Settings are provided so that the Net-Link will either record continuously 
between the start and stop times, or will only record on seeing events on 
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any combination of the four trigger inputs. When not in “record 
continuously” mode, a combination of both triggers to watch and 
whether each of these triggers will activate recording on active high or 
low can be selected. 

When all appropriate fields have valid information in them for a 
recording to setup, the user should click the “Set event” button. A popup 
prompt window will appear to inform the user of the success or 
otherwise of setting the recording event. 

Alternatively, if the user simply wishes to start recording immediately, 
without any particular stop time, they can click the “Record now” button. 

View recording events. This option will only appear if the connected 
unit has been fitted with a hard disk. A popup window will appear as 
follows: 

 
This allows the user to select any of the 128 possible recording events 
and see whether it is set, the recording name and the start and stop 
times. If a selected event is set, a pushbutton allows the user to unset it. 
For reference, the current unit time is also displayed at the bottom of the 
popup window. 

Delete recording(s). This option will only appear if the connected unit is 
fitted with a hard disk. A popup window will appear as follows: 
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The window presents a list of all recordings on the hard disk. The user 
simply needs to select the appropriate recording and select “Delete 
session”. An information window will appear informing the user of either 
success or failure of the deletion. 

Record now/Stop recording. This option will only appear if the 
connected unit is fitted with a hard disk. It provides a quicker method of 
initiating or stopping a recording than the more protracted action of 
setting up a recording event. The option displayed depends on whether 
or not the Net-Link is currently recording. In this way, the user can just 
make the Net-Link start or stop recording immediately. A recording 
started in this manner will continue until the user explicitly stops it. The 
recording will be named “Automatic recording”. 

The Management sub-menu contains the following options: 

Set unit time. This option allows the user to set the Net-Link units real 
time clock. 

Set encryption key/type. This options enables the user to set up the 
encryption and decryption in use throughout the Net-Link setup. This 
may include the decryption on any input receivers, encryption on any 
input encoders, decryption in place on the Net-Links video decoders and 
the re-encryption of thumbnails. The Net-Link application will detect the 
setup of the Net-Link and only present the user with the appropriate 
options. A popup window will appear. This will appear as follows: 
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Encryption/decryption type can be applied independently of the 
encryption/decryption key for decoders, receivers and encoders. For 
thumbnail re-encryption the key and type are applied simultaneously. 
For this reason, drop-down selections are provided where appropriate to 
apply encryption/decryption type only. When a new selection is made, 
the “Apply scrambling types” button will be enabled, allowing the user to 
set the type.  

To apply a key, the relevant key type must be selected in the lower part 
of the window, the key entered in the appropriate field(s) and then the 
part(s) of the system selected in the upper part of the window to which 
the user wishes to apply the key. In this way it is straightforward to set 
an identical key into multiple parts of the system simultaneously by 
checking multiple checkboxes. When this has been done, the “Apply 
key” button will be enabled, allowing the user to complete the process of 
setting the key. 

Input slot routing. This option allows the user to setup which of the two 
input slots is being used. Currently Net-link only supports one channel 
for use at any one time. Selecting this options will bring up the following 
popup window: 
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The greyed out option for “source 2” is intended for future releases of 
Net-Link. 

Setup slot 1/Setup slot 2. These options allow the user to control the 
setup of either input slot and will only appear if there is anything 
connected to either input slot. The appearance of the options in the 
menu will depend on the type of unit connected to each input slot – 
either as “Setup slot N encoder” or “Setup slot N receiver”, where N is 
the number of the input slot. 

The popup window that appears in the case of an encoder will be as 
follows: 

 
The bitrate which the user can setup will be the total transport stream 
bitrate. Thus if audio encoding is enabled the available video bitrate will 
be this total bitrate less the audio bitrate. The rest of the settings are all 
as detailed in the documentation for the encoder. 

The popup window that appears in the case of a receiver is as follows: 
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The settings for a receiver are all identical to those detailed in the 
documentation for the receiver. 

The Advanced sub-menu contains the following options: 

Send diagnostic commands to inputs/DSP. This is a more advanced 
option, enabling the user to send diagnostic messages to the Net-Link 
or to either of the two input slots of a Net-Link. This should only be used 
when trying to diagnose faults with a Net-Link unit and under the 
direction of an employee of domo Limited. 

Send diagnostic commands to Net-link. This is another advanced 
option, enabling the user to send commands to the main Net-Link. This 
should only be used when trying to diagnose faults with a Net-Link unit 
and under the direction of an employee of domo Limited. 

Enable full rate streaming. This option switches the Net-Link unit into 
full rate streaming mode, suitable for use on local networks. In full rate 
streaming mode, the Net-Link cannot be controlled from the Net-Link 
application. Therefore, when this option is selected the application will 
automatically close down it’s connection to the Net-Link. While the full 
rate stream can be played in the application, subsequent control of the 
Net-Link must be carried out through the browser control interface. 

Video input. This options only appears when the connected Net-Link 
unit is fitted with a Kramer video switch. A popup window will appear as 
follows: 
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The software will read from the video switch the available number of 
inputs and provide the appropriate selections in the dropdown box. 

 

7.6.2 Local content icon 

 This icon represents locally stored content on the PC. Dropping 
this icon into a slot will present options for either thumbnails or full frame 
rate video. Upon clicking one of these options the user will be presented 
with a window to browse to the location of either the directory for 
thumbnails or the file for full frame rate video. 

 

7.6.3 Full rate streams icon 

 This icon represents full rate multicast streams on the local 
network. Dropping this icon into a slot will bring up a window listing any 
multicast streams available: 
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A “play” icon in white and blue appears next to any available services 
within the streams. In the above screenshot the available service is 
named “e-Link_1”. Clicking this icon will cause the application to begin 
playing the service. 

 

7.7 Playback controls area 

On the right hand side of the main window is an area which contains a 
number of buttons to enable the user to control playback of either 
thumbnails or full frame rate video, or to start and stop recording 
sessions. 

This part of the window always applies to the currently highlighted area 
of the main workspace. Buttons will be enabled or disabled depending 
on whether or not their actions can be applied to the current area. 

A slider control may also appear as well as text labels and an audio icon 
relating to playback. 

7.7.1 Playback buttons  

The actions of these buttons will always be carried out on the 
workspace area currently highlighted in red. Depending on the contents 
of the currently active workspace area the icons on these buttons will 
appear either green (active and ready to use) or grey (disabled). 

The actions of the different buttons are as follows: 
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 Play. This button will cause the thumbnails/video to be played at 
it’s normal rate. If the thumbnails/video are already playing at normal rate 
this button will appear disabled. 

 Pause. This button will pause the playback of the 
thumbnails/video at the present position. 

 Stop. This button will stop playback of the thumbnails/video. In 
contrast to the pause control, this will return the position to the beginning 
of the recording for when playback is restarted. Also, the display in the  
workspace area will revert to blue screen. 

 Increment playback rate. This button will double the rate at which  
 thumbnails/video are played back, up to a maximum of 8 x normal rate. 

 Decrement playback rate. This button will halve the rate at which  
 thumbnails/video are played back, down to minimum of 1/8 x normal  rate. 

 Single step. This button will put playback into pause mode, if it 
isn't already, and then advance playback by a single frame or thumbnail 
each subsequent time it is clicked. 

 Rewind. This button will only be enabled when playing back 
previously recorded thumbnails. It will force playback into reverse. 
Playback can be subsequently returned to normal by using the play 
button. 
 

7.7.2 Recording buttons 

 If there is only one connected Net-Link unit, or the currently 
selected slot of the work area contains a stream from a connected Net-
Link unit, the application will send a message to this Net-Link unit to 
start a recording. Otherwise, if there is more than one connected Net-
Link unit, a pop-up window will appear allowing the user to select which 
unit they wish the recording to be started on. 

 To stop a recording started in this way, the stop recording 
button on the right hand side of the main window should be clicked. 

7.7.3 Slider control 

As well as the pushbutton controls, there is a slide bar which appears 
next to the buttons when playing back previously recorded full rate video 
or thumbnails. This shows the user the relative position of playback 
within the recording. When playback is paused, the bar can be dragged 
to a different position. When playback is resumed it will then continue 
from this new position. 
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7.7.4 Thumbnail playback 

When playing back thumbnails (whether a live stream or previously 
recorded thumbnails), a recent thumbnail history will be displayed to the 
right of the playback controls area: 

 
The number of recent thumbnails being displayed can be altered by 
going to the “Options” menu and selecting “Thumbnail display options”. 
Any number of recent thumbnails from 0 to 16 can be selected. 

 

7.8 Toolbar and menus 

The following menu options are provided in the Net-Link application. 

7.8.1 File menu 

New. This option creates a new configuration document.  

Open. This option allows the user to open a previously saved 
configuration. The application will attempt to re-establish any Net-Link 
connections saved in this configuration file. This will require the user to 
re-enter their username and password for each connection. 

Save. This option will save the current configuration. If the configuration 
is currently an untitled document, the user will be prompted for a 
filename and location to save to. 

Save as. This option will save the current configuration, always 
prompting the user for a filename and location. 

Exit. This option exits the Net-Link application. 
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As well as these options, a list of up to four most recently opened 
configuration files appears. 

7.8.2 Edit menu 

Recording times. This option enables the user to setup recording 
times, as previously documented, on any of the current connections. 

Set unit time. This option enables the user to setup the real time clock 
on any currently connected Net-Link units. 

Delete recording session. This option enables the user to delete 
previously recordings on the hard disks of any currently connected Net-
Link units. 

Change license code. This option enables a new license code for the 
Net-link application to be entered. This should only be done when a 
valid new license code is supplied from domo. 

7.8.3 View menu 

Divide grid. This option, when enabled, allows the user to divide the 
currently selected workspace area into four sub-areas. This option will 
not appear enabled if dividing into four would lead to sub-areas smaller 
than the minimum dimensions that the application allows for (100 x 122 
pixels). 

Undivide grid. This option, when enabled, allows the user to return 
from four sub-areas to one larger area. If there is only content in one of 
the four sub-areas, then this content will appear in the larger area after 
the division has been broken. If there is content in more than one of the 
sub-areas, then the content from the currently selected area will appear 
in the larger area, with the content of the other areas destroyed. 

Toolbar. This option allows the user to toggle whether or not the 
application toolbar is visible. 

Status bar. This option allows the user to toggle whether or not the 
application status bar is visible. 

7.8.4 Options menu 

Autoloop file playback. This option allows the user to toggle whether 
or not recordings being played back will automatically loop back to the 
beginning when the end of the recording is reached. 

Thumbnail display options. This option allows the user to select the 
number of recent thumbnails to display in the playback controls area of 
the application. 

Thumbnail stream options. This option allows the user to setup 
various features of thumbail streaming. A popup window will appear as 
follows: 
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Setting a maximum bandwidth for the thumbnails is useful for occasions 
when a Net-Link unit does not have a large bandwidth available for 
streaming. Limiting the bandwidth will prevent the Net-Link unit trying to 
flood a limited connection with too much information. 

The option to take a stream from the serial port is for specialist 
applications when a stream can be fed into a computer through a serial 
port. The baudrate setting is also used for this purpose. These options 
should not normally be used. 

The default resolution can be set to either “Normal” or “Reduced”. 
Normal resolution will be 288 line thumbnail images for a PAL video 
source or 240 line images for an NTSC video source. Reduced 
resolution will be 144 line thumbnail images for a PAL source or 120 line 
images for an NTSC source. 

The thumbnail packet size can help in producing an optimum 
transmission bandwidth. The default value of 1448 bytes is normally 
sufficient. 

Full rate stream options. This option allows the user to change the 
address and port number being scanned for announcements about full 
rate streams available on the local network. A popup window will appear 
as follows: 

 
Recording options. This option allows the user to setup various default 
features of recording. A popup window will appear as follows: 
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Recording can be setup either continuously or to record on active high 
or active low of different triggers. When retrieving recordings that have 
been activated by triggers the amount of preroll recording to download 
can be setup here. This can be set to either 10, 20 or 30 seconds. 

Unit hard disk status. This option allows the user to see the hard disk 
capacity and current occupancy on any currently connected Net-link 
units. 

Create new connection. This option allows the user to create a new 
connection to a Net-link unit, as documented earlier. 

Logging options. This option allows the user to select what information 
is written to the applications log file. It should not normally be necessary 
to alter these settings. 

Connection options. This option allows the user to alter various 
settings related to how the Net-Link application connects to Net-Link 
units. A popup window will appear as follows: 

 
The “Message receive timeout” field specifies how long the application 
will wait for a reply to each message it sends to a Net-Link unit. The 
user may wish to set this to a longer timeout when latency is higher 
between the application and the unit. 

The “Download timeout” field specifies how long the application will wait 
without receiving any further part of a download before it automatically 
exits the download. Also, the “Exit download on timeout” option, when 
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checked, specifies whether the application will automatically exit from a 
download at all. 

The remaining settings, for operation mode are described in section 5.2 
of this handbook. 

7.8.5 Help menu 

Help topics. This option brings up a window with information to help the 
user use the application. 

About. This option brings up a popup window displaying version and 
copyright information as well as the applications serial number for the 
computer it is installed on. This serial number is needed when 
contacting domo for a new license code. 

7.8.6 Toolbar buttons 

The toolbar provides buttons as shortcuts to some of the menu options: 

 This provides a shortcut to the “New” option in the “File” menu. 

 This provides a shortcut to the “Open” option in the “File” menu. 

 This provides a shortcut to the “Save” option in the “File” menu. 

 This provides a shortcut to the “Divide” option in the “View” menu. 

 This provides a shortcut to the “Undivide” option in the “View” menu. 

 This provides a shortcut to the “Delete recording session” option in 
the “Edit” menu. 

 This provides a shortcut to the “Unit hard disk status” option in the 
“Options” menu. 

 This provides a shortcut to the “Create new connection” option in 
the “Options” menu. 

 This provides a shortcut to the “About” option in the “Help” menu. 
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8  Retrieving stored content 

When the connection icon has been dropped into the workspace area 
and the stored content option selected, a new window should appear 
similar to the following, showing content stored on the Net-Link unit’s 
hard disk: 

 
This gives the title of each recording, along with boxes containing its 
beginning and ending times and dates. These times and dates can be 
adjusted using the arrow controls on the side of these boxes or by 
highlighting a box and directly typing the desired time/date. In this way 
the user can specify the exact portion of the recording which they wish 
to download. All the user needs to then do is click either the 
"Thumbnails" or the "Full rate" button to the right of the time/date 
controls and the application will begin the download. When the 
download is complete a window will appear playing back the retrieved 
recording. 

If the user selects the “Triggers” button for a recording, a further window 
will appear showing a graph of any trigger activity that has occurred 
during the recording: 
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Clicking on this graph will bring up cursors which can be positioned to 
set the part of the recording the user wishes to download: 

 
These cursors can be clicked and dragged along the recording timeline. 
Buttons labeled “+” and “-“ allow the user to zoom in or out of the graph 
respectively. 

The type of content to download is specified by clicking either the 
“Retrieve thumbnails” or “Retrieve full rate” buttons. 

By default all recordings will be downloaded into temporary files on the 
local computer, which will then be removed later by the software. Should 
the user wish to store the recording to a more permanent file/directory 
on the local machine, the "Store permanently" checkbox to the right of 
the "Thumbnails" button should be checked. Before the download 
commences the user will be presented with a pop-up browse window to 
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select a directory for the thumbnails to be stored to or a file for the full 
frame rate video. 
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9 Decryption keys 

All Net-Link products are set up initially to encrypt all content using the 
AES standard. 128-bit or 256-bit keys may be used. When playing back 
content a pop-up window will appear prompting for a decryption key: 

 
 

With the default setup, the user should simply click the "Use default" 
button on this pop-up window for the application to begin decrypting and 
playing back the thumbnails/full frame rate video. Otherwise the user 
should select the appropriate decryption type (AES128 or AES256) and 
enter the correct key. 
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